We've identified and mitigated the issue. Users should now be able to use the web site as normal.
Posted Feb 04, 2026 - 12:22 GMT
Investigating
Our web site is currently being slow. We're aware of this and working to discover the cause and fix the problem. Anyone using our web site. We apologise for the problem.
Posted Feb 04, 2026 - 12:06 GMT
This incident affected: Collections Search, Requesting & Sign-in, and Website & Content.