Image zoom in the viewer is not working as expected

Incident Report for Wellcome Collection

Resolved

This incident has been resolved.
Posted May 08, 2026 - 16:35 BST

Investigating

We're currently seeing that images zoomed into in our viewer are pixelated and not displaying correctly. We have made our third party partner aware of this and asked them to discover the cause and fix the problem. Anyone using zoom in the viewer will be affected. Images can still be downloaded from the viewer and zoomed in on that way. We apologise for this issue.
Posted May 08, 2026 - 15:56 BST
This incident affected: Image Services.